US1 Region degraded
Incident Report for Achievers
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 15:00 EST
Identified
Currently we have networking issues in the US1 region. This has been identified as an upstream issue. The platform is not down however it may be slower than normal.
Posted Feb 14, 2024 - 14:40 EST
This incident affected: Web Interface (US1 (GCP)).