At this time the issue with Google Cloud appears to have been mitigated and our US3 region appears to be operational again. We will continue to monitor the platform to ensure things are working smoothly.
Posted Jun 12, 2025 - 16:39 EDT
Identified
Google is currently experiencing an infrastructure outage that is causing performance degradation across our customer base. Specifically, we are experiencing:
Moderate Degradation: NA1, US1, UK1, BE1 Severe Degradation: US3
Our SRE Team is actively engaged with Google to understand the issue and potential resolution times to help bring our customer programs back up.
Posted Jun 12, 2025 - 15:35 EDT
This incident affected: Web Interface (NA1 (GCP), UK1 (GCP), US1 (GCP), US3 (GCP)).