Canada region availability issues
Incident Report for Achievers
Resolved
This incident has been resolved.
Posted Oct 26, 2023 - 21:13 EDT
Monitoring
At this time the issue with programs occasionally not looking as expected appears to be resolved. We are continuing to monitor the situation.
Posted Oct 26, 2023 - 20:51 EDT
Investigating
We are currently investigating an issue impacting the platform for users connecting to our Canadian (NA1) region.
Posted Oct 26, 2023 - 19:15 EDT